FollowMee Forums   Home    Forums    Active Topics    Search
    Login
FollowMee Forums >> General Discussion >> General Discussion >> Query Error with &trackerstate=1 in javascript (used to work) Edit: working again .. never mind
Query Error with &trackerstate=1 in javascript (used to work) Edit: working again .. never mind
Author Topic
CostProDirect


Newbie

Join Date: 2015-09-04
Posts: 4

Posted: 2018-12-07 01:05:25 AM

edit: And this morning it''s working just fine again. Must have been something on your end??

Anyway I guess it''s fixed!!

cheers
------------

Today we were getting ''''no data returned for your query'''' when &trackerstate=1 is appended to _url in the javascript embed.

It worked for weeks and weeks and now it doesn''''t. I took out that and it''''s fine --- but we need to have our devices not show on the map when the app isn''''t running.

Is something hinky going on ?

thanks
Administrator


Best of the Best


Join Date: 2010-01-27
Posts: 1309

Posted: 2018-12-07 08:53:28 PM

I am guessing that all your devices were in stopped state. As a result, this api call (with trackerstate=1) did not return any device with tracking state. Later on today, the FollowMee app was started in one or more devices. The same api call would return some data and the error message was gone.

CostProDirect


Newbie

Join Date: 2015-09-04
Posts: 4

Posted: 2018-12-07 10:41:22 PM

Hmm.. ok. As far as I know they were all up but we''ll keep track of that kind of thing
Administrator


Best of the Best


Join Date: 2010-01-27
Posts: 1309

Posted: 2018-12-09 10:24:53 AM

If you want to always show the last known location for all your devices, regardless of the tracker state, you should remove this parameter "&trackerstate=1" from your api url.


  FollowMee.com DMG Forums 3.2